Main

October 08, 2004

so i never forget again

Just to remind myself incase I ever forget again or lose my bookmark. The Debian Snapshot archive is located at http://snapshot.debian.net/. Sorry for the interruption and we now return you to your regularly scheduled program.

May 28, 2004

fork stuck in warsync 0.9.8

That's right kids, exactly two months after 0.9.7 was released, the world can now enjoy in the wonder that is Warsync 0.9.8. Good stuff in this one, and it's actually a useful program now. Make sure you take this survey of what else to include in 1.0.

May 05, 2004

warsync website...sorta

In preparation of the upcoming Warsync version 0.9.8 release, I have "launched" the Warsync web site by simply posting the readme as the index page for the site. Yeah, so nothing special, but at least it's better than nothing. Enjoy.

July 17, 2003

verifying upgrades

Just a reminder to myself. After upgrading packages on linux boxen, to double check if you need to restart any programs, simply run:
sudo lsof +L1 | grep /lib/ | cut -c-10 | uniq
Enjoy!

Update 2006-09-19: Turns out this has stopped working with recent versions of lsof. (bug #264985) So your best bet now is to use this command:
sudo lsof | grep '/lib/.*inode' | cut -c-10 | sort | uniq

June 01, 2003

mapserver 3.6.5

Just in time for the MapServer Users Meeting beginning Friday I have packaged MapServer 3.6.5 for Debian GNU/Linux. As this package has not been fully tested I do not yet recommend it's usage in a production environment and I await feedback. This package is built against Debian Sid (unstable) and will not work on Woody, the current stable Debian 3.0 distribution.

To download and install simply add the following lines to your /etc/apt/sources.list file:

deb http://paulbaker.net/debian unstable main
deb-src http://paulbaker.net/debian unstable main

Of course you may download the .deb files directly by pointing your web browser at http://paulbaker.net/debian/dists/unstable/main/binary-i386/science/

February 27, 2003

libclass-contract-perl

While I was going through hell with my laptop today, I thought I would download my latest project at work to my linux workstation and see how well it ran. Class::Contract wasn't installed on it. Quick search of the Debian package archive and I found that it has yet to be packaged for Debian. So while my Powerbook was busy repairing itself, I decided to package it up. So you can now download libclass-contract-perl 1.14-1 from my unofficial Debian APT source:

deb http://paulbaker.net/debian stable main
deb-src http://paulbaker.net/debian stable main

Assuming my sponsor comes through it should be officially included in Debian Sid in the next few days. I'll keep you posted.